Sitio para la difusión de conocimiento informático. 

Twitter RSS

Actualizando Prelude SIEM

Actualización de Prelude SIEM

Agregando el repositorio de Prelude:

Prelude SIEM ha agregado el soporte para RedHat RHEL6 instalando el paquete «prelude-ids-rhel-2-1.noarch.rpm»:
– Ingresamos a la siguiente URL y descargamos el paquete mencionado: https://www.prelude-ids.org/projects/prelude/files
– rpm -ivh prelude-ids-rhel-2-1.noarch.rpm

Esto no agregará el repositorio de Prleude para RHEL y CentOS, para poder actualizar los paquetes de Prelude mediante YUM.

Actualización Manual:

• Descargar los paquetes src del sitio oficial de Prelude SIEM:
https://www.prelude-ids.org/projects/prelude/files:
libprelude-1.0.1-3el6.src.rpm
prelude-correlator-1.0.1-2el6.src.rpm
prelude-lml-1.0.1-2el6.src.rpm
prelude-notify-0.9.2-1el6.src.rpm
prewikka-1.0.1p1-1el6.src.rpm
libpreludedb-1.0.1-2el6.src.rpm
prelude-manager-1.0.2-1el6.src.rpm

• Pasamos a copilar los RPMs:
rpmbuild –rebuild «nombre.src.rpm». Los archivos generados quedarán en el directorio “/root/rpmbuld/i386/”:
rpmbuild –rebuild libprelude-1.0.1-3el6.src.rpm
rpmbuild –rebuild libpreludedb-1.0.1-2el6.src.rpm
rpmbuild –rebuild prelude-correlator-1.0.1-2el6.src.rpm
rpmbuild –rebuild prelude-lml-1.0.1-2el6.src.rpm
rpmbuild –rebuild prelude-manager-1.0.2-1el6.src.rpm
rpmbuild –rebuild prelude-notify-0.9.2-1el6.src.rpm
rpmbuild –rebuild prewikka-1.0.1p1-1el6.src.rpm

• Para instalar cada RPM generado ejecutamos el siguiente comando: rpm -ivh «nombre.rpm»:
– rpm -Uvh libprelude-1.0.1-3.el6.i386.rpm libprelude-devel-1.0.1-3.el6.i386.rpm libprelude-perl-1.0.1-3.el6.i386.rpm libprelude-python-1.0.1-3.el6.i386.rpm libprelude-ruby-1.0.1-3.el6.i386.rpm
– rpm -Uvh libpreludedb-1.0.1-2.el6.i386.rpm libpreludedb-devel-1.0.1-2.el6.i386.rpm libpreludedb-mysql-1.0.1-2.el6.i386.rpm libpreludedb-perl-1.0.1-2.el6.i386.rpm libpreludedb-python-1.0.1-2.el6.i386.rpm
– rpm -Uvh prelude-lml-1.0.1-2.el6.i386.rpm prelude-lml-devel-1.0.1-2.el6.i386.rpm
– rpm -Uvh prelude-manager-1.0.2-1.el6.i386.rpm prelude-manager-db-plugin-1.0.2-1.el6.i386.rpm prelude-manager-devel-1.0.2-1.el6.i386.rpm prelude-manager-smtp-plugin-1.0.2-1.el6.i386.rpm prelude-manager-xml-plugin-1.0.2-1.el6.i386.rpm
– rpm -Uvh prelude-correlator-1.0.1-2.el6.noarch.rpm
– rpm -Uvh prewikka-1.0.1p1-1.el6.noarch.rpm
– rpm -Uvh prelude-notify-0.9.2-1.el6.noarch.rpm

Nota: En caso de recibir un “warnning” por una nueva versión de un archivo nuevo, se deben analizar las diferencias y ver de utilizar la nueva versión.

 
Home Linux OS Prelude SIEM Actualizando Prelude SIEM